Zoom Service Issues

Incident Report for USC Provost IT

Resolved

This issue has been resolved. If you continue to experience any Zoom-related problems, please email helpdesk@provost.usc.edu or call (213) 821-0009. Thank you.
Posted Apr 17, 2025 - 07:44 PDT

Identified

Zoom is currently experiencing global service issues affecting Zoom Meetings, Zoom Phone, and other Zoom products and services. Some users may be able to connect while others cannot. There is no estimated time for a fix yet, but USC users may use Teams as a temporary alternative.
Posted Apr 16, 2025 - 13:06 PDT
This incident affected: Zoom Zoom Meetings and Zoom Zoom Phone.