Network Issues
Incident Report for USC Provost IT
Resolved
We believe this issue has been resolved. If you continue to experience any network-related problems, please email helpdesk@provost.usc.edu or call (213) 821-0009. Thank you.
Posted Sep 01, 2021 - 07:36 PDT
Investigating
Information Technology Services is currently experiencing network issues which may affect access to Provost IT-provided services and the internet on the USC Secure Wireless and USC Guest Wireless networks. ITS is working to restore service as soon as possible.
Posted Aug 25, 2021 - 13:52 PDT
This incident affected: USC Network & Other USC Systems.