Microsoft Service Outage
Incident Report for USC Provost IT
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 18:07 PDT
Update
Microsoft has put a workaround in place that has resolved this issue. If you are still experiencing problems, please try fully restarting your computer, smartphone or other device and try again. If you still have problems, please contact Provost IT at (213) 821-0009 or by emailing helpdesk@provost.usc.edu.
Posted Sep 28, 2020 - 18:06 PDT
Monitoring
Microsoft is making progress resolving this issue although services are still impacted.
Posted Sep 28, 2020 - 17:09 PDT
Identified
Microsoft is currently experiencing service issues affecting the Office 365 platform. Staff and faculty may have trouble with logging in to their email or collaboration services, as well as sending and receiving messages. Authentication or password messages may appear even though nothing is wrong with your username or password. Microsoft is actively working on fixing this issue.
Posted Sep 28, 2020 - 15:05 PDT
This incident affected: Provost Email and USC Network & Other USC Systems.