Email Delivery and Receiving Delays

Incident Report for USC Provost IT

Resolved

Microsot has resolved this incident. As their systems catch up, users may receive delay errors while queued emails are reprocessed. Late emails from throughout the day yesterday may also begin to trickle in. If you still experience issues, please contact Provost IT via email at helpdesk@provost.usc.edu or call (213) 821-0009.
Posted Jan 23, 2026 - 09:51 PST

Monitoring

Microsoft continues to make progress in resolving the email delivery issues experienced globally today. Some older messages and lingering service problems may cause ongoing errors. We will provide another update as service continues to get restored.
Posted Jan 22, 2026 - 21:27 PST

Identified

Microsoft is currently experiencing technical problems which are causing delays in sending and receiving emails to both USC and non-USC people and email addresses. These problems are unrelated to USC. Microsoft believes the issue is in the process of being resolved, but there is no exact time to restore service. We will provide an update when we have more information to share.
Posted Jan 22, 2026 - 14:11 PST
This incident affected: Provost Email.