Customer Support Interruption
Incident Report for USC Provost IT
Resolved
Customer service operations have now returned to normal operations.
Posted 12 months ago. Jun 08, 2018 - 12:37 PDT
Identified
Provost IT customer support is currently unavailable due to a fire alarm in our customer support offices. For assistance, email helpdesk@provost.usc.edu.
Posted 12 months ago. Jun 08, 2018 - 09:40 PDT
This incident affected: USC Network & Other USC Systems.