Network Issues
Incident Report for USC Provost IT
Resolved
We believe this issue has been resolved. If you continue to experience any network-related problems, please email helpdesk@provost.usc.edu or call (213) 821-0009. Thank you.
Posted Sep 10, 2020 - 11:04 PDT
Update
This issue is still ongoing and ITS is still attempting to resolve it. There is no estimated time to resolution.
Posted Sep 10, 2020 - 09:31 PDT
Identified
Information Technology Services is currently experiencing network issues which may affect access to Provost IT-provided services across USC's campuses. The cause of this outage appears to be with a third-party network provider in another state, although ITS is working to restore service as soon as possible.
Posted Sep 10, 2020 - 08:42 PDT
This incident affected: USC Network & Other USC Systems.