Email Delivery Issues
Incident Report for USC Provost IT
Resolved
We believe this issue has been resolved. If you continue to experience any related issues, please email helpdesk@provost.usc.edu or call (213) 821-0009. Thank you.
Posted Aug 03, 2020 - 09:58 PDT
Update
ITS is still continuing to investigate this issue. There is no ETA for repair at this time.
Posted Aug 03, 2020 - 09:17 PDT
Investigating
An issue is preventing the proper flow of inbound and outbound email. Users may receive error messages sending and receiving emails, or their emails inbound or outbound may not go through at all. The cause of this issue is not yet known.
Posted Aug 03, 2020 - 08:45 PDT
This incident affected: Provost Email.