We believe this issue has now been resolved. If you continue to experience any problems, please email helpdesk@provost.usc.edu or call (213) 821-0009. Thank you.
Posted Nov 26, 2024 - 08:56 PST
Monitoring
Microsoft's fixes are having a noticeable improvement on the availability of 365 services. We are continuing to monitor but are also noticing that service quality approves to be mostly restored.
Posted Nov 25, 2024 - 15:36 PST
Update
Microsoft continues to work on resolving the issues affecting their infrastructure. Outlook and other Office applications, including Outlook on the web, are still functioning abnormally. There are no updates on a time to resolution as of yet.
Posted Nov 25, 2024 - 11:25 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 25, 2024 - 10:46 PST
Identified
This issue appears to be isolated to various Microsoft products, including their Office 365/Microsoft 365 suite of products (Outlook, Teams, SharePoint, etc.). Microsoft is aware of the issues, which are affecting customers globally, and they are working to restore service as quickly as possible. There is no estimated time to resolve yet.
Posted Nov 25, 2024 - 10:46 PST
Investigating
Information Technology Services is currently experiencing network issues which may affect access to Provost IT-provided services across USC's campuses. The cause of this outage is not known at this time although ITS is working to restore service as soon as possible.
Posted Nov 25, 2024 - 08:38 PST
This incident affected: Provost Email and USC Network & Other USC Systems.