Network Issues
Incident Report for USC Provost IT
Resolved
We believe this issue has been resolved. If you continue to experience any network-related problems, please email helpdesk@provost.usc.edu or call (213) 821-0009. Thank you.
Posted 6 months ago. Nov 26, 2018 - 10:59 PST
Investigating
Information Technology Services is currently experiencing network issues which may affect access to the internet and Provost IT-provided services across USC's campuses. This outage is also affecting the voice network and causing phones to not ring when called. The cause of this outage is not known at this time although ITS is working to restore service as soon as possible.
Posted 6 months ago. Nov 26, 2018 - 08:09 PST
This incident affected: USC Network & Other USC Systems.