Office 365 Service Outage
Incident Report for USC Provost IT
Resolved
We believe Microsoft has resolved this issue. If you continue to experience Office 365 authentication or service problems, please email helpdesk@provost.usc.edu or call (213) 821-0009. Thank you.
Posted 4 months ago. Jan 29, 2019 - 19:53 PST
Monitoring
Microsoft believes this issue is mostly resolved. While residual errors may still persist, most problems should have gone away and connections should succeed at this point. We are continuing to monitor.
Posted 4 months ago. Jan 29, 2019 - 15:13 PST
Identified
Microsoft is currently experiencing issues that are affecting multiple Office 365 services, including email, calendaring, Skype for Business and others. These issues may cause Outlook to re-prompt users for their credentials repeatedly or show errors when logging into Office 365 services online. They are aware of the cause of the global problem and are working to restore service as soon as possible.
Posted 4 months ago. Jan 29, 2019 - 13:50 PST
This incident affected: Provost Email.