Network Issues
Incident Report for USC Provost IT
Resolved
We believe ITS has resolved this issue. If you continue to experience any network-related problems, please email helpdesk@provost.usc.edu or call (213) 821-0009. Thank you.
Posted Oct 11, 2019 - 12:09 PDT
Update
ITS is continuing to troubleshoot the cause of this issue. They have not provided an estimated time to restore services.
Posted Oct 11, 2019 - 08:47 PDT
Investigating
Information Technology Services is currently experiencing network issues which may affect access to USC's wireless networks and other campus systems and applications. The cause of this outage is not known at this time although ITS is working to restore service as soon as possible.
Posted Oct 11, 2019 - 08:14 PDT
This incident affected: USC Network & Other USC Systems.