Network Issues
Incident Report for USC Provost IT
Resolved
We believe this issue has been resolved. If you continue to experience any network-related problems, please email helpdesk@provost.usc.edu or call (213) 821-0009. Thank you.
Posted 9 months ago. Aug 30, 2018 - 17:24 PDT
Investigating
Information Technology Services is currently experiencing network issues which may affect access to Provost IT-provided services across USC's campuses. The cause of this outage is not known at this time although ITS is working to restore service as soon as possible.
Posted 9 months ago. Aug 30, 2018 - 16:17 PDT
This incident affected: USC Network & Other USC Systems.