Email Performance & Delivery Issues
Incident Report for USC Provost IT
Resolved
We believe this issue has been resolved per guidance from Microsoft. If you continue to experience any email-related issues, please email helpdesk@provost.usc.edu or call (213) 821-0009. Thank you.
Posted 6 months ago. Dec 10, 2018 - 14:47 PST
Monitoring
Microsoft is reporting that they are experiencing service issues with Office 365 email. Due to infrastructure problems at Microsoft, some USC users may have delays sending, receiving and searching for messages, as well as slowness when using Outlook. Microsoft has implemented a fix and users who were affected should be noticing improvements soon.
Posted 6 months ago. Dec 10, 2018 - 10:19 PST
This incident affected: Provost Email.