Network Issues
Incident Report for USC Provost IT
Resolved
This issue has been resolved by ITS on Thursday evening.
Posted Nov 20, 2017 - 09:22 PST
Investigating
Information Technology Services is currently experiencing network issues which may affect access to Provost IT-provided services across USC's campuses. The cause of this outage is not known at this time although ITS is working to restore service as soon as possible.
Posted Nov 16, 2017 - 10:12 PST