Phone Support System Issues
Incident Report for USC Provost IT
Resolved
We believe this issue has been resolved. If you continue to experience any phone-related issues, please contact ITS at (213) 740-5555. Thank you.
Posted 6 months ago. Nov 12, 2018 - 12:04 PST
Identified
Some users are having difficulty calling Provost IT's helpdesk line at (213) 821-0009 (campus extension 1-0009). This issue is not isolated to our helpdesk; numerous campus phone lines are experiencing issues. We are investigating these issues with ITS and hope to have the phone support line working again soon. In the mean time, if you require assistance, please email helpdesk@provost.usc.edu.
Posted 6 months ago. Nov 12, 2018 - 11:05 PST
This incident affected: USC Network & Other USC Systems.