Network Issues
Incident Report for USC Provost IT
Resolved
We believe this issue has now been resolved. If you continue to experience any network-related problems, please email helpdesk@provost.usc.edu or call (213) 821-0009. Thank you.
Posted about 1 year ago. Apr 17, 2018 - 15:54 PDT
Update
ITS is still continuing to locate and troubleshoot the cause of the network issues. There is still no estimated time to resolution as of now.
Posted about 1 year ago. Apr 17, 2018 - 11:36 PDT
Update
ITS is still working on a resolution to these issues, and phones and the wired/wireless networks are still experiencing degraded performance.
Posted about 1 year ago. Apr 17, 2018 - 09:52 PDT
Investigating
Information Technology Services is currently experiencing network issues which may affect access to Provost IT-provided services across USC's campuses. The cause of this outage is not known at this time although ITS is working to restore service as soon as possible.
Posted about 1 year ago. Apr 17, 2018 - 08:51 PDT