Internet Connectivity Issues
Incident Report for USC Provost IT
Resolved
We believe this issue has been resolved. If you continue to experience any network-related problems, please email helpdesk@provost.usc.edu or call (213) 821-0009. Thank you.
Posted 8 months ago. Oct 10, 2018 - 14:03 PDT
Update
ITS will be performing network maintenance early tomorrow morning to attempt to fix these issues. We will provide an another update tomorrow.
Posted 8 months ago. Oct 09, 2018 - 20:21 PDT
Identified
Information Technology Services is currently experiencing network issues which may affect access to the internet from campus. ITS is working to restore service as soon as possible.
Posted 8 months ago. Oct 09, 2018 - 13:12 PDT
This incident affected: USC Network & Other USC Systems.