Office 365 Login Problems
Incident Report for USC Provost IT
Resolved
We believe ITS has resolved this issue. If you continue to experience any problems, please email helpdesk@provost.usc.edu or call (213) 821-0009. Thank you.
Posted 8 months ago. Oct 04, 2018 - 11:35 PDT
Update
Office 365 access via the web and various desktop and mobile devices is still broken. ITS is still working on fixing the issue but there is no estimated time to fix.
Posted 8 months ago. Oct 04, 2018 - 10:41 PDT
Update
ITS is continuing to experience issues with Office 365 logins. There is still no estimated time to fix the issue.
Posted 8 months ago. Oct 04, 2018 - 10:01 PDT
Investigating
ITS is currently investigating this issue.
Posted 8 months ago. Oct 04, 2018 - 09:35 PDT
Identified
Information Technology Services (ITS) is currently having an issue which is preventing staff and faculty from accessing their Office 365 email accounts via the web. Staff and faculty may see a 503 error or the message that the server is "currently unable to handle this request" when trying to log into their email. ITS is working to resolve this issue but has no estimated time to fix.
Posted 8 months ago. Oct 04, 2018 - 09:35 PDT
This incident affected: USC Network & Other USC Systems.